summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhut2024-04-19 19:29:16 +0200
committerhut2024-04-19 19:40:07 +0200
commit760c22b885ddb50a8118b2bf12668a3a837238a7 (patch)
treecf2fe322c6adcfdda0e30f930f974df7b766ce5d /PKGBUILD
downloadaur-760c22b885ddb50a8118b2bf12668a3a837238a7.tar.gz
added outfly-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ccc6171e7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Roman Zimbelmann <hut@hut.pm>
+# Maintainer: Roman Zimbelmann <hut@hut.pm>
+
+pkgname=outfly-git
+pkgver=0.7.2_17_gbf3c8d5
+pkgrel=1
+pkgdesc="A breathtaking 3D space game in the rings of Jupiter"
+arch=('any')
+url="https://codeberg.org/hut/outfly"
+license=('GPL-3.0-only')
+depends=('glibc' 'libcap' 'gcc-libs' 'alsa-lib' 'systemd-libs')
+makedepends=('git' 'rust' 'libx11' 'pkgconf')
+provides=('outfly')
+source=("$pkgname::git+https://codeberg.org/hut/outfly")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --always --tags | sed -e 's/-/_/g' -e '1s/^v//'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cargo build --release --features "x11 wayland"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "target/release/outfly" "$pkgdir/usr/bin/outfly"
+}