aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro Henrique2019-11-20 13:11:36 -0300
committerPedro Henrique2019-11-20 13:11:36 -0300
commit60da257c89f4870fd7331f0a278e5347f440a3a7 (patch)
tree67fe31867ccc19a1551ea54184ec66142ed1a1ab /PKGBUILD
parentc2a8334358e3b14cfbc237a64c5efd582f70da72 (diff)
downloadaur-60da257c89f4870fd7331f0a278e5347f440a3a7.tar.gz
Update to version 3.3.3 (python 3.8 support) and fix some bugs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 950968e9cb62..cedb4a7b7742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pedro Henrique <pedro00dk@gmail.com>
pkgname=overgrive
-pkgver=3.3.2
-pkgrel=1
+pkgver=3.3.3
+pkgrel=0
pkgdesc='A complete Google Driveā„¢ desktop client solution for Linux'
arch=('x86_64')
url='https://www.thefanclub.co.za/overgrive'
@@ -16,19 +16,27 @@ conflicts=('overgrive')
install='overgrive.install'
changelog=
-source=('https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.2-0-any.pkg.tar.xz')
-noextract=('overgrive-3.3.2-0-any.pkg.tar.xz')
-md5sums=('e33e8990b637ecbacea36f5a8ea23b7c')
+source=('https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.3-0-any.pkg.tar.xz')
+noextract=('overgrive-3.3.3-0-any.pkg.tar.xz')
+md5sums=('09b65ef826d11f5b82400683cf35e3f2')
prepare() {
- tar --extract --file='./overgrive-3.3.2-0-any.pkg.tar.xz'
- rm -- './overgrive-3.3.2-0-any.pkg.tar.xz'
+ tar --extract --file=./overgrive-3.3.3-0-any.pkg.tar.xz
+ rm -- ./overgrive-3.3.3-0-any.pkg.tar.xz
+ # chmod 0755 ./opt/thefanclub/overgrive/__pycache__/overgrive.cpython-38.pyc
+
+ # script to execute through terminal
+ mkdir --parents ./usr/bin/
+ echo -e '/opt/thefanclub/overgrive/venv/bin/python /opt/thefanclub/overgrive/__pycache__/overgrive.cpython-38.pyc' \
+ > ./usr/bin/overgrive
+
+ # update .desktop files
sed --in-place -- \
- 's+Exec=python3+Exec=/opt/thefanclub/overgrive/venv/bin/python3+g' \
- './usr/share/applications/overgrive.desktop' \
- './opt/thefanclub/overgrive/overgrive-autostart.desktop'
+ 's+Exec=.*+Exec=sh /usr/bin/overgrive+g' \
+ ./usr/share/applications/overgrive.desktop \
+ ./opt/thefanclub/overgrive/overgrive-autostart.desktop
}
package() {
- cp --recursive -- './opt/' './usr/' "${pkgdir}/"
+ cp --recursive -- ./opt/ ./usr/ "${pkgdir}/"
}