summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarvin Delgado2019-07-01 19:04:13 -0400
committerDarvin Delgado2019-07-01 19:04:13 -0400
commit7caa87b208d393a5d0299680e98e468893091589 (patch)
tree9f5fd71f82e934d290355793e80b00b157974d76 /PKGBUILD
downloadaur-7caa87b208d393a5d0299680e98e468893091589.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..173ba534f50b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Darvin Delgado <dnmodder@gmail.com>
+pkgname=oversteer
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Graphical application to configure Logitech Wheels."
+arch=("any")
+url="https://github.com/berarma/oversteer"
+license=('GPL3')
+depends=("python" "python-gobject" "python-pyudev" "python-xdg" "gettext" "appstream-glib" "desktop-file-utils")
+optdepends=("jstest-gtk-git: Test the steering wheel")
+makedepends=("meson")
+source=("https://github.com/berarma/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("429df91ee381e0fd1b0958ee5bb17adbb6458c6157b0193acc6f4ab63c48722e")
+
+build() {
+ cd "$pkgname-$pkgver"
+ meson build --prefix="/usr"
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir/" ninja -C build install
+}