summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaddie Zhan2022-01-18 17:33:03 +0800
committerMaddie Zhan2022-01-18 17:34:21 +0800
commit6e1a49c77176dc4061c9a7cb012b98f5fd5fb6b1 (patch)
tree0fcb7de1162cbabdf9bc8e7454616627f862ac69 /PKGBUILD
parent208744899f279ed98584dbc028630f2c46245442 (diff)
downloadaur-overture.tar.gz
v1.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 25 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd0ed232a17e..9d9095498117 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Maddie Zhan <maddie@emzee.be>
pkgname=overture
-pkgver=1.6
+pkgver=1.8
pkgrel=1
pkgdesc="A DNS upstream switcher written in Go in order to purify DNS records"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/shawn1m/overture"
license=("MIT")
provides=("overture")
-optdepends=("dnsmasq: advanced DNS configuration")
+optdepends=("dnsmasq: advanced DNS configuration" "redis: dns caching")
makedepends=("go>=1.12")
backup=("etc/overture/config.json" "etc/overture/hosts" "etc/overture/china_ip_list.txt" "etc/overture/gfwlist.txt")
@@ -17,20 +17,24 @@ install=${pkgname}.install
_gourl=github.com/shawn1m/${pkgname}
source=("git+https://github.com/shawn1m/${pkgname}.git#tag=v${pkgver}"
- "china_ip_list.txt"
- "domain_ttl.txt"
- "config.json"
- "gfwlist.txt"
+ "config.yml"
"hosts"
+ "domain_ttl"
+ "domain_primary"
+ "domain_alternative"
+ "ip_network_primary"
+ "ip_network_alternative"
"overture.service")
sha256sums=("SKIP"
- "82948c5f5d806b384a4eda405fba0691c8df10cd1293d116a80d427ebe802e18"
- "107cb3b11c4a06d5a804c4375c56890fd8e2006ecd978ad76332dc480e0e1946"
- "e8ceec2fa23e92fc56db895b40503ed0dde6ebcb46d98b9fb43e9760515b0d7a"
- "b9faeacafaf842f6643a81b6d85c60bf7d045132b661f787e6ced19318d4d049"
- "02c82a9ffce44f1517b0b64380e11ea41d15812267a0fbff97221b5a6921df50"
- "9529e60a7963fd284ad2afb99d28803af90f16db99a1ba662ac5c7fd52903d3f")
+ "fbcfe2e13118045ca6608e833795ea1e3e8595d2bc608e468f002a6c5c9c4c17"
+ "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
+ "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
+ "01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"
+ "01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"
+ "01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"
+ "01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"
+ "3ff281e0fe9407b414e6c4be573bdd0afc660c961d8eb6d93bfec2e160025590")
_goroot="/usr/lib/go"
@@ -47,11 +51,13 @@ package() {
install -Dm0755 "$srcdir/${pkgname}/out/$pkgname" "$pkgdir/usr/bin/$pkgname"
# Config and other files
- install -Dm0644 "$srcdir/config.json" "$pkgdir/etc/overture/config.json"
- install -Dm0644 "$srcdir/domain_ttl.txt" "$pkgdir/etc/overture/domain_ttl.txt"
- install -Dm0644 "$srcdir/china_ip_list.txt" "$pkgdir/etc/overture/china_ip_list.txt"
- install -Dm0644 "$srcdir/gfwlist.txt" "$pkgdir/etc/overture/gfwlist.txt"
+ install -Dm0644 "$srcdir/config.yml" "$pkgdir/etc/overture/config.yml"
install -Dm0644 "$srcdir/hosts" "$pkgdir/etc/overture/hosts"
+ install -Dm0644 "$srcdir/domain_ttl" "$pkgdir/etc/overture/domain_ttl"
+ install -Dm0644 "$srcdir/domain_primary" "$pkgdir/etc/overture/domain_primary"
+ install -Dm0644 "$srcdir/domain_alternative" "$pkgdir/etc/overture/domain_alternative"
+ install -Dm0644 "$srcdir/ip_network_primary" "$pkgdir/etc/overture/ip_network_primary"
+ install -Dm0644 "$srcdir/ip_network_alternative" "$pkgdir/etc/overture/ip_network_alternative"
# Service
install -Dm0644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
@@ -63,4 +69,7 @@ package() {
post_upgrade() {
echo "If you're upgrading from pre-1.4 versions, please make sure your config.json"
echo "is up to date with the v1.4 format, or else Overture might not start properly."
+ echo
+ echo "If you're upgrading from previous versions that uses config.json, please migrate"
+ echo "your configuration to config.yml."
}