summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-12-27 13:14:23 +0200
committerAdrian Perez de Castro2021-12-27 13:14:23 +0200
commitd7b51f1958d3dea259115a469200d6671231fdce (patch)
treefaf86793e9592c9f4baefa57ed60cda86cc6aac2 /PKGBUILD
parent6008ae97acfce9f91f8effca66726f783c2f1c9b (diff)
downloadaur-owl.tar.gz
Fix documentation generation with newer lowdown versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be557226dbba..8fb7812f8fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=owl
pkgdesc='Parser generator for visibly pushdown languages.'
pkgver=4
-pkgrel=1
-url='https://github.com/ianh/owl'
+pkgrel=2
+url=https://github.com/ianh/owl
arch=(x86_64)
license=(custom)
depends=(glibc)
makedepends=(make lowdown)
source=("${url}/archive/${pkgname}.v${pkgver}.tar.gz")
-sha512sums=('13fb588bf015827fd9311e5e115c861b875e4eefa0723e410e665c530b0a2f2922f0951debd5f378a2f7e9b39de65e942b5d2cc0c50acd957e8bf609059b0611')
+b2sums=('f983f229b33f4e0abcb0def610ede958303d88fd6dd05abdf86bee21b766d84bf2d78ce6c1708d995f2d39b179ba02c88b5dec0dbdc5a4ba963e6b08b52eb162')
build () {
cd "${pkgname}-${pkgname}.v${pkgver}"
@@ -18,8 +18,7 @@ build () {
local mdfile
for mdfile in doc/*.md *.md ; do
echo "Rendering ${mdfile}..."
- lowdown -e autolink -e fenced -e strike -e tables -E smarty \
- -s -o "${mdfile%.md}.html" "${mdfile}"
+ lowdown -Thtml -s -o "${mdfile%.md}.html" "${mdfile}"
done
}