summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Bromilow2023-12-25 22:42:00 +0000
committerMichael Bromilow2023-12-25 22:42:13 +0000
commitc0b54895cc3a0cb59a5a5bb5a7ef487bebd8dba1 (patch)
treee0952e8aea426f19ca572c984f054fda2c32bb7c /PKGBUILD
parent7ed1490157df41869a63223f3c499cc6bb9b54a8 (diff)
downloadaur-c0b54895cc3a0cb59a5a5bb5a7ef487bebd8dba1.tar.gz
Add assets from git repo into install w/ post_install message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19d17af10b4f..99d327cc3ac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=oxeylyzer-git
pkgver=r364.d40c28f
-pkgrel=1
+pkgrel=2
pkgdesc="Alternative keyboard layout analyzer"
url="https://github.com/O-X-E-Y/oxeylyzer"
license=('Apache')
@@ -11,6 +11,7 @@ depends=('glibc' 'gcc-libs')
makedepends=('git' 'cargo')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+install=oxeylyzer.install
source=('git+https://github.com/O-X-E-Y/oxeylyzer')
sha256sums=('SKIP')
@@ -27,7 +28,7 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ cargo build --frozen --release --all-features
}
check() {
@@ -37,5 +38,7 @@ check() {
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm0755 -t "$pkgdir/usr/bin" "target/release/${pkgname%-git}"
+ install -Dm0755 -t "$pkgdir/usr/bin/${pkgname%-git}" "target/release/${pkgname%-git}" "config.toml" "languages_default.cfg"
+ install -Dm0755 -t "$pkgdir/usr/lib/${pkgname%-git}" "config.toml" "languages_default.cfg"
+ cp -a "static" "$pkgdir/usr/lib/${pkgname%-git}"
}