summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKeaton Bruce2021-10-01 16:26:46 -0400
committerKeaton Bruce2021-10-01 16:26:46 -0400
commit25576fa5241101f90cb6b2349086deec7d1d5e40 (patch)
tree14458a3c9ef5527bbe6029480ac0f43047fa961b /PKGBUILD
parent9e762f046f57e6ed5c71a8fb7308d592d6cba3ba (diff)
downloadaur-25576fa5241101f90cb6b2349086deec7d1d5e40.tar.gz
Add pkgver() and update things so that using autoupdating tools should work in keeping it up-to-date
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39a6d4394c21..2f39388cd3a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Keaton Bruce <akbruce@protonmail.ch>
pkgname='p2pool-git'
-pkgver=master
+_pkgname='p2pool'
+pkgver=1.0.r16.g2a3cd13
pkgrel=1
pkgdesc='Decentralized pool for Monero mining'
-arch=('x86_64' 'armv7h' 'aarch64')
-url="https://github.com/SChernykh/p2pool"
+arch=('x86_64' 'armv7h' 'aarch64' 'i686')
+url='https://github.com/SChernykh/p2pool'
provides=('p2pool')
depends=('libuv' 'zeromq' 'libsodium' 'libpgm')
optdepends=()
makedepends=('cmake' 'git')
conflicts=('p2pool')
-license=('GPL')
+license=('GPL3')
backup=()
-source=("$pkgname::git+${url}.git")
+source=("$_pkgname::git+${url}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
git submodule init
git submodule update
- mkdir build
+ mkdir -p build
# Removing libgss from build dependencies.
sed -i 's/gss//g' CMakeLists.txt
}
build() {
- cd "$pkgname/build"
+ cd "$_pkgname/build"
cmake .. -DCMAKE_BUILD_TYPE=Release
make -j$(nproc)
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
install -Dm775 "build/p2pool" "${pkgdir}/usr/bin/p2pool"
#install -Dm644 "${srcdir}/p2pool.service" "${pkgdir}/usr/lib/systemd/system/p2pool@.service"
#install -Dm0644 "${srcdir}/p2pool.sysusers" "${pkgdir}/usr/lib/sysusers.d/p2pool.conf"