summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIntelligide2017-02-01 18:41:48 +0100
committerIntelligide2017-02-01 18:41:48 +0100
commitd1ff40748b37193c783e7ef12d8c9465a0608ba9 (patch)
tree70627138230c8abecb776573a2b88e77c5e5a45d /PKGBUILD
downloadaur-d1ff40748b37193c783e7ef12d8c9465a0608ba9.tar.gz
v0.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b29c1f03b3af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=p7gui
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A GUI for p7."
+arch=("x86_32" "x86_64")
+url="https://github.com/intelligide/p7gui"
+license=('LGPL3')
+groups=()
+depends=('qt5-base' 'libp7>=2.0')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('https://github.com/intelligide/p7gui/archive/0.0.1.tar.gz')
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/p7gui-$pkgver"
+ qmake p7gui.pro
+ make
+}
+
+package() {
+ cd "$srcdir/p7gui-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+}