summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrpkak2023-09-24 13:17:31 +0200
committerrpkak2023-09-24 13:17:31 +0200
commitbba063fd1a19e2d19960253b2bb9babf6a0241f9 (patch)
treec53cfec2d02b907c9c5c4a94af65d8198f39dd9e /PKGBUILD
downloadaur-bba063fd1a19e2d19960253b2bb9babf6a0241f9.tar.gz
Version 1.8.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c2efb5d511b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: rpkak <rpkak@users.noreply.github.com>
+pkgname='packcc'
+pkgver=1.8.0
+pkgrel=1
+epoch=
+pkgdesc="A parser generator for C"
+arch=('x86_64')
+url="https://arithy.github.io/packcc/"
+license=('MIT')
+groups=()
+depends=(glibc)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/arithy/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('811516f71196958a6e5b22755951ea0d48e09e948e1b75dd86af19923aae2947')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver/src"
+ "${CC:-cc}" $CFLAGS -c -o packcc.o packcc.c
+ "${CC:-cc}" $LDFLAGS -o packcc packcc.o
+}
+
+package() {
+ install -Dm644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname-$pkgver/src/packcc" "$pkgdir/usr/bin/packcc"
+}