summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Langlois2018-02-15 21:29:47 -0700
committerTyler Langlois2018-02-15 21:29:47 -0700
commit326ed5dfb58531c6771461d3528780db9498c680 (patch)
tree5df44f4944fd8a89d978a9abd25a9cf1efe6245a /PKGBUILD
parent9114ef660b26228641d2bff5ff35df571c96ca32 (diff)
downloadaur-packetbeat-bin.tar.gz
update beats to 6.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6063b2586d25..d41389121b75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=packetbeat-bin
_pkgbase=${pkgname%%-bin}
-pkgver=5.2.0
+pkgver=6.2.1
pkgrel=1
pkgdesc='An open source network packet analyzer that ships data to Elasticsearch (precompiled)'
arch=('i686' 'x86_64')
@@ -14,12 +14,12 @@ options=('!strip')
provides=("$_pkgbase")
conflicts=("$_pkgbase")
source=("$_pkgbase.service")
-sha256sums=('acc6d21a3fe1a2b5f721f0423b4752ffd2c69b37c1c8323edac0d583ae73daaa')
+sha256sums=('407fda47ace0e9de3dc27bf504693a3e432bf377c9a5e6772377b2ebb3a8f2e4')
source_i686=("https://artifacts.elastic.co/downloads/beats/$_pkgbase/$_pkgbase-$pkgver-linux-x86.tar.gz")
source_x86_64=("https://artifacts.elastic.co/downloads/beats/$_pkgbase/$_pkgbase-$pkgver-linux-x86_64.tar.gz")
-sha256sums_i686=('1edd5d93d30f9ad8169e3a1ca62b02d2f3575e809d4f619b6949eeb64cc35b3a')
-sha256sums_x86_64=('51dc83da0d6904afbfb04c276c48f33e12fa4e7bdd31bc54d2b20b482447f54f')
+sha256sums_i686=('fcf470ea40f1a64bdf6557124a1f332c0998cad52c0776cec6d09128715b317f')
+sha256sums_x86_64=('59e4f955457b4b5bae578714d7c261538ccf798e10295acf1fbd33d07260a95f')
package() {
if [[ $CARCH == 'i686' ]] ; then
@@ -36,14 +36,16 @@ package() {
install -D -m755 $_pkgbase "$pkgdir/usr/bin/$_pkgbase"
- for f in $_pkgbase.{{,full.}yml,template{,-es2x}.json} ; do
+ for f in $_pkgbase.{,reference.}yml fields.yml ; do
install -D -m644 $f "$pkgdir/etc/$_pkgbase/$f"
done
- for f in NOTICE README.md scripts/* ; do
+ for f in NOTICE.txt README.md ; do
install -D -m644 $f "$pkgdir/usr/share/$_pkgbase/$f"
done
+ cp -r kibana "$pkgdir/usr/share/$_pkgbase"
+
install -D -m644 "$srcdir/$_pkgbase.service" \
"$pkgdir/usr/lib/systemd/system/$_pkgbase.service"
}