summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-05-27 22:19:23 +0200
committerSefa Eyeoglu2022-05-27 22:19:23 +0200
commit77d8c55e317f595dd7bd5530dd0dd3468f2c5297 (patch)
treec2bfdd94014d9091f18368b5da8729edda705c9b /PKGBUILD
parentac082924ce85cd2861f884e294c05ace7c3fe6ab (diff)
downloadaur-77d8c55e317f595dd7bd5530dd0dd3468f2c5297.tar.gz
upgpkg: packwiz-git r211.e71b63e-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a72ee9cfd611..563161ced55a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
-# Maintainer: Caleb Fontenot <foley2431 at gmail dot com>
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Contributor: Caleb Fontenot <foley2431 at gmail dot com>
+
pkgname=packwiz-git
-pkgver=f2c6b89
-url="https://github.com/comp500/packwiz"
+pkgver=r211.e71b63e
pkgrel=1
pkgdesc="A command line tool for creating minecraft modpacks."
-arch=('any')
-license=('MIT')
-depends=('go')
-source=("git+https://github.com/comp500/packwiz.git")
-md5sums=('SKIP')
+arch=("x86_64")
+url="https://packwiz.infra.link/"
+license=("custom:MIT")
+depends=("glibc")
+makedepends=("git" "go")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/packwiz/packwiz.git")
+md5sums=("SKIP")
pkgver() {
- cd "$srcdir/packwiz"
- #git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
- git rev-parse --short HEAD
+ cd "${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/packwiz"
- go build
+ cd "${pkgname%-git}"
+
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ .
}
package() {
- cd "$srcdir/packwiz"
- install -Dm755 packwiz "${pkgdir}/usr/bin/packwiz"
+ cd "${pkgname%-git}"
- }
+ install -Dm755 packwiz "$pkgdir/usr/bin/packwiz"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}