summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Fontenot2021-01-25 17:49:32 -0600
committerCaleb Fontenot2021-01-25 19:46:08 -0600
commitac082924ce85cd2861f884e294c05ace7c3fe6ab (patch)
treeba2679c3805a0ac31cd7cb3cbdd4b9797104d4fc /PKGBUILD
downloadaur-ac082924ce85cd2861f884e294c05ace7c3fe6ab.tar.gz
Initial commit
Initial commit Initial commit Initial commit Initial commit Initial commit Initial commit Initial commit Initial commit Initial commit Ready for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a72ee9cfd611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caleb Fontenot <foley2431 at gmail dot com>
+pkgname=packwiz-git
+pkgver=f2c6b89
+url="https://github.com/comp500/packwiz"
+pkgrel=1
+pkgdesc="A command line tool for creating minecraft modpacks."
+arch=('any')
+license=('MIT')
+depends=('go')
+source=("git+https://github.com/comp500/packwiz.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/packwiz"
+ #git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd "$srcdir/packwiz"
+ go build
+}
+
+package() {
+ cd "$srcdir/packwiz"
+ install -Dm755 packwiz "${pkgdir}/usr/bin/packwiz"
+
+ }