summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Münch2021-01-30 12:56:53 +0100
committerChristian Münch2021-01-30 12:56:53 +0100
commitbcaab5079f22d11a549959543b1e51326c9e1f2b (patch)
tree02d797b78e019a630c449e9ef7707c11ea684d7d /PKGBUILD
parent39a65b37c60ade19403c088d06feb927eb7c8446 (diff)
downloadaur-bcaab5079f22d11a549959543b1e51326c9e1f2b.tar.gz
Update only on non metered Internet and with the database unlocked
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 842106552517..14cf7182807b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
-# Maintainer: Christian Münch <christian@muench-worms.de>
-pkgname=pacman-auto-update
-pkgver=1.0.1
-pkgrel=2
+#! /bin/bash
+pkgname="pacman-auto-update"
+pkgver=1.1.0
+pkgrel=1
+arch=("any")
+install="${pkgname}.install"
pkgdesc="Install a systemd service triggered by a timer to run automatic pacman package updates"
-arch=('any')
-url="https://github.com/cmuench/pacman-auto-update.git"
-license=('GPL')
-install=${pkgname}.install
+url="https://github.com/cmuench/pacman-auto-update"
+license=("GPL2")
+depends=("systemd")
+source=("git+${url}")
+md5sums=("SKIP")
changelog=
-depends=(systemd)
-source=("${pkgname}.service"
- "${pkgname}.timer")
-md5sums=('8813d126331d900ab7368bcab156b56d'
- 'e68d3424ad02a8a78de4fae56945f09f')
package() {
- install -d -m755 "$pkgdir/usr/lib/systemd/system"
- install -m644 ${pkgname}.service "$pkgdir/usr/lib/systemd/system/"
- install -m644 ${pkgname}.timer "$pkgdir/usr/lib/systemd/system/"
+ cp --recursive "${srcdir}/${pkgname}/root"/* "${pkgdir}"
}
+