aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordtluna2018-12-15 01:36:20 +0300
committerdtluna2018-12-15 01:36:20 +0300
commit3211921634a930b74d35b10ca718c92109db2fbd (patch)
tree8344289f2b5e3a6eb1220a7a153a6296a60bbf4e /PKGBUILD
parent6201ec8ce89ccec1250cdf833ad672b5ce223820 (diff)
downloadaur-3211921634a930b74d35b10ca718c92109db2fbd.tar.gz
Include the hook into repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d567149172d..26ae2e42583d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: dtluna dtluna@waifu.club
pkgname=pacman-backup-hook
pkgver="1.0.0"
-pkgrel=1
+pkgrel=2
pkgdesc="A pacman hook that will save the list of your packages to /etc/pkglist.txt on every install and removal"
arch=('any')
url="https://git.voluntaryism.club/dtluna/pacman-backup-hook"
@@ -9,10 +9,16 @@ license=('unknown')
depends=(
'pacman>=5.1'
)
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('532fcbc1fc4dbb93b8b7e729d53bc5e37c7067eb9f491c31cdafd54b2fa7d56e')
+source=(
+ 'pacman-backup.hook'
+ 'LICENSE'
+)
+sha256sums=(
+ 'e05db077598b8cd441dfbb878a3f8886a07c69068bf481a06574c50c250a6055'
+ 'faf2caea6f44f13dc7d138c1e6106bce82b0c416260dc4a8538f7b2d7f6a033c'
+)
package() {
- cd "$srcdir/$pkgname"
- install -Dm644 pacman-backup.hook $pkgdir/usr/share/libalpm/hooks/pacman-backup.hook
+ install -Dm0644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname
+ install -Dm0644 $srcdir/pacman-backup.hook $pkgdir/usr/share/libalpm/hooks/pacman-backup.hook
}