summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Schanz2018-01-07 20:34:31 +0100
committerMarkus Schanz2018-01-07 20:36:38 +0100
commit98f0cf1a4fafd827266009d78bf193b690942068 (patch)
tree4bdb25248f4ad82dec44ca5cf9f3558135577bc8 /PKGBUILD
parent766320157ec3499c287e88d48ee02cb6c1e104b6 (diff)
downloadaur-98f0cf1a4fafd827266009d78bf193b690942068.tar.gz
The backup is now performed prior AND after a package upgrade!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06f1ed3f1584..e116b1c15312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Markus Schanz <coksnuss@googlemail.com>
pkgname=pacman-boot-backup-hook
-pkgver=1.1
+pkgver=1.2
pkgrel=1
-pkgdesc="Pacman hook that uses rsync to backup the /boot directory prior to upgrades of the linux or systemd package."
+pkgdesc="Pacman hook that uses rsync to backup the /boot directory prior and post to upgrades of the linux or systemd package."
arch=('any')
license=('custom:MIT')
changelog=CHANGELOG
depends=('rsync')
source=('LICENSE'
- '50_bootbackup.hook'
- 'pacman-boot-backup.conf'
- 'pre-kernel-upgrade-rsync')
+ 'backup-boot-partition'
+ 'bootbackup.post.hook'
+ 'bootbackup.pre.hook'
+ 'pacman-boot-backup.conf')
md5sums=('ac9ac34b11dd5a53d096a734ab677479'
- 'f731f5aee99eecc75d6c0686742d3a23'
- '27819f1384ade1a543a1c110bf9fc846'
- '0fdff0b79eb987701a2c54c40910fed0')
+ '3cd8131ceb4563164ab12cc7b7d61ed6'
+ '688911051c14693e4a65e043ecb5bde4'
+ '05868b278d10a4d5b1493d8b33d34139'
+ 'c5d37420cddc494cba64930ea54518b1')
package() {
install -m 0755 -d $pkgdir/usr/share/licenses/$pkgname
@@ -25,8 +27,9 @@ package() {
install -m 0644 $srcdir/pacman-boot-backup.conf $pkgdir/etc
install -m 0755 -d $pkgdir/usr/share/libalpm/hooks
- install -m 0644 $srcdir/50_bootbackup.hook $pkgdir/usr/share/libalpm/hooks
+ install -m 0644 $srcdir/bootbackup.post.hook $pkgdir/usr/share/libalpm/hooks
+ install -m 0644 $srcdir/bootbackup.pre.hook $pkgdir/usr/share/libalpm/hooks
install -m 0755 -d $pkgdir/usr/share/libalpm/scripts
- install -m 0755 $srcdir/pre-kernel-upgrade-rsync $pkgdir/usr/share/libalpm/scripts
+ install -m 0755 $srcdir/backup-boot-partition $pkgdir/usr/share/libalpm/scripts
}