summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Schanz2017-12-31 00:54:55 +0100
committerMarkus Schanz2017-12-31 01:28:11 +0100
commite50ce5ebdecae990efb103fc1d8836eba455d7a9 (patch)
tree7b3595028c1dcbdcf1b0bc76d6ab8c4323027a8f /PKGBUILD
downloadaur-e50ce5ebdecae990efb103fc1d8836eba455d7a9.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3268a9102f2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Markus Schanz <coksnuss@googlemail.com>
+pkgname=pacman-boot-backup-hook
+pkgver=1.0
+pkgrel=1
+pkgdesc="Pacman hook that uses rsync to backup the /boot directory prior to upgrades of the linux or systemd package."
+arch=('any')
+license=('custom:MIT')
+changelog=CHANGELOG
+depends=('rsync')
+
+source=('LICENSE'
+ '50_bootbackup.hook')
+md5sums=('ac9ac34b11dd5a53d096a734ab677479'
+ 'e2a3034dbae1e27ed782c8b44cbd7f72')
+
+package() {
+ install -m 0755 -d $pkgdir/usr/share/licenses/$pkgname
+ install -m 0755 -d $pkgdir/usr/share/libalpm/hooks
+
+ install -m 0644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname
+ install -m 0644 $srcdir/50_bootbackup.hook $pkgdir/usr/share/libalpm/hooks
+}