aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas DOREL2020-10-24 00:09:43 +0200
committerJonas DOREL2020-10-24 00:09:43 +0200
commitc5fc60bf1efde4979acc23fbeb83c43832b282e6 (patch)
treea0dd14d61846c8a5775d30dbae9afae073b209df /PKGBUILD
downloadaur-c5fc60bf1efde4979acc23fbeb83c43832b282e6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44fb6da96ff4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jonas DOREL <jonas at dorel dot me>
+pkgname=pacman-hook-list-installed-packages
+pkgver=latest
+pkgrel=1
+pkgdesc="Pacman hook to list installed packages in /etc/packages-list-native.txt and /etc/packages-list-foreign.txt"
+arch=('any')
+url="https://gitlab.com/jdorel-archlinux/pacman-hook-list-installed-packages"
+license=('GPL')
+makedepends=('git')
+source=('list-installed-packages.hook')
+md5sums=('SKIP')
+sha256sums=(
+ '010b00d9804e65643609f7605661e9a16535729668bd9533db1d83daa7dce197'
+)
+
+pkgver() {
+ printf "latest"
+}
+
+package() {
+ install -Dm 644 $srcdir/list-installed-packages.hook "$pkgdir/usr/share/libalpm/hooks/list-installed-packages.hook"
+}