summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordszryan2020-10-07 14:36:40 +1100
committerdszryan2020-10-07 14:36:40 +1100
commit0954d608d9980f320ebd234d34de4353634f5bf9 (patch)
tree3a38fe1fa37e95b5ab00283cc04d19dd7d9997f0 /PKGBUILD
parentc08d16bf5f8e43b1496daf9e278cb10711a8c94d (diff)
downloadaur-0954d608d9980f320ebd234d34de4353634f5bf9.tar.gz
added support for unattended builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32491b9fd93a..c771bf6556c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: dszryan
pkgname=pacmanity-git
pkgver=3.0.1
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Keeps a list of installed packages in a Gist at your GitHub account"
arch=('x86_64' 'i686')
@@ -27,7 +27,10 @@ package() {
install -m664 "$srcdir/$pkgname/src/pacmanity.hook" "$pkgdir/usr/share/libalpm/hooks/zzz-pacmanity.hook"
# run
- if [[ -z "$SKIP_FIRST_RUN" ]]; then
- . $pkgdir/usr/lib/pacmanity/pacmanity.sh && pacmanity_install
+ . $pkgdir/usr/lib/pacmanity/pacmanity.sh
+ if [[ -z "$GIST_ID" ]]; then
+ pacmanity_install
+ else
+ pacmanity_update
fi
}