summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordszryan2020-10-07 17:25:44 +1100
committerdszryan2020-10-07 17:25:44 +1100
commit3148349336a12aea18d154fd48007a3146f785da (patch)
tree953da5cbd7b8e11573008a5f6cda619477a01c69 /PKGBUILD
parent10e80d423c56582b13bef7b3fc8932cbbd8c7484 (diff)
downloadaur-3148349336a12aea18d154fd48007a3146f785da.tar.gz
swapped git source and changed version calc formula
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10712f1f2971..22b4a83e650e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: dszryan
pkgname=pacmanity-git
-pkgver=3.0.1
-pkgrel=5
+pkgver=r47.71a7d21
+pkgrel=1
epoch=1
pkgdesc="Keeps a list of installed packages in a Gist at your GitHub account"
arch=('x86_64' 'i686')
-url="https://github.com/DerekTBrown/${pkgname/-git/}"
+url="https://github.com/dszryan/${pkgname/-git/}"
license=('GPL')
#groups=('ALPM' 'Backup' 'gist' 'pacman')
depends=('pacman>=5.0' 'gist>=4.5.0')
makedepends=('git')
conflicts=('pacmanity')
-source=("${pkgname/-git/}::git+https://github.com/DerekTBrown/${pkgname/-git/}.git#branch=master")
+source=("${pkgname/-git/}::git+https://github.com/dszryan/${pkgname/-git/}.git#branch=master")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname/-git/}"
- git describe --all --exact-match `git rev-parse HEAD` | sed "s|tags/||g"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
@@ -26,10 +26,10 @@ package() {
install -m664 "$srcdir/${pkgname/-git/}/src/pacmanity.hook" "$pkgdir/usr/share/libalpm/hooks/zzz-pacmanity.hook"
# run
- . $pkgdir/usr/lib/pacmanity/pacmanity.sh
- if [[ -f "/etc/pacmanity" ]]; then # if file is present, assume it is maanged externally (via a build system)
- GIST_ID=$(sed "s|GIST_ID=||g" /etc/pacmanity) pacmanity_update
+ if [[ -r "/etc/pacmanity" ]]; then # if file is present, assume it is maanged externally (via a build system)
+ . $pkgdir/usr/lib/pacmanity/pacmanity.sh
else
+ source $pkgdir/usr/lib/pacmanity/pacmanity.sh
pacmanity_install
fi
}