summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancesco Minnocci2020-08-25 15:18:38 +0200
committerFrancesco Minnocci2020-08-25 15:18:38 +0200
commitd6260f70e0fd91b81633639fd0654a820e5fb937 (patch)
treeddc148727d81e25218cc8111e7dada6b54a9f0d3 /PKGBUILD
downloadaur-d6260f70e0fd91b81633639fd0654a820e5fb937.tar.gz
Initial commit: add neovim diff patch and release latest upstream
version of the script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e754b70d0e62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Ramana Kumar <firstname at member.fsf.org>
+# Contributor: Jesus Alvarez <jeezusjr@gmail.com>
+pkgname=pacnews-neovim-git
+pkgver=v1.0.r0.gd78c8ac
+pkgrel=1
+pkgdesc="Find .pacnew files and merge them with a neovim diff - updated git tag"
+arch=(any)
+url="https://github.com/pbrisbin/dotfiles/blob/v1.0/tag-scripts/local/bin/pacnews"
+license=('unknown')
+makedepends=('git')
+provides=('pacnews-git')
+conflicts=('pacnews-git')
+source=(
+ "git+https://github.com/pbrisbin/dotfiles.git#tag=v1.0"
+ # Patches
+ nvim.patch
+)
+md5sums=('SKIP'
+ 'c8532d9984cbcb2dc97d2a07bb7a23de')
+
+pkgver() {
+ cd "${srcdir}/dotfiles"
+
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/dotfiles"
+
+ patch -Np1 -i "$srcdir/nvim.patch"
+}
+
+package() {
+ cd "${srcdir}/dotfiles/tag-scripts/local/bin"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ install ${pkgname%-neovim-git} "${pkgdir}/usr/bin/"
+}
+
+# vim:set ts=2 sw=2 et: