summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2017-11-07 16:15:43 +1000
committerMark Blakeney2017-11-07 16:16:11 +1000
commitf38bf21fcd1d2a5cf50c691a318d1349a9003d76 (patch)
tree29d76730e2fe0e61faedcde7ad198016ca4f6383 /PKGBUILD
downloadaur-f38bf21fcd1d2a5cf50c691a318d1349a9003d76.tar.gz
Pacsync renamed to pacpush
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3304960c81f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=pacpush
+pkgver=2.0
+pkgrel=1
+pkgdesc="Utility to push an Arch host's package and AUR caches to other hosts"
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python" "rsync" "sudo" "openssh" "pacaur")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+replaces=("pacsync")
+conflicts=("pacsync")
+md5sums=('220183a74f8623de309507f920a08047')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: