summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNazar Vinnichuk2020-06-02 17:20:50 +0300
committerNazar Vinnichuk2020-06-02 17:20:50 +0300
commitcf975a9afd4c1bfd8113f1be0be179294a8f624e (patch)
treed7b8113a49112f35973bd545603743c17aad40f5 /PKGBUILD
parent38468857769eec2c177b7c008332d972456c35f3 (diff)
downloadaur-cf975a9afd4c1bfd8113f1be0be179294a8f624e.tar.gz
Do not spit hyphens in pkgver.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 299789fa4ab3..cd2502d8e901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nazar Vinnichuk <nazar.vinnichuk at tutanota dot com>
pkgname=pacwall-git
_pkgname=${pkgname%-git}
-pkgver=1.1
+pkgver=1.1.r1.gd36b113
pkgrel=1
pkgdesc="Dependency graph of installed packages on your wallpaper."
url="http://github.com/Kharacternyk/${_pkgname}"
@@ -19,7 +19,7 @@ sha256sums=(SKIP)
pkgver() {
cd "${srcdir}/${_pkgname}"
- local _version="$(git describe --tags --match 'v*')"
+ local _version="$(git describe --tags --match 'v*' | sed 's/-/.r/' | sed 's/-/./')"
printf "${_version#v}"
}