summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNazar Vinnichuk2020-03-30 15:08:14 +0300
committerNazar Vinnichuk2020-03-30 15:08:14 +0300
commite5cfa82a0f80ee1057519eb4b1c01002275609b1 (patch)
tree2ef5a37275e4f9d94f028cef3e8fdcb7d3c10977 /PKGBUILD
downloadaur-e5cfa82a0f80ee1057519eb4b1c01002275609b1.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f5472cf7d6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=pacwall-git
+_pkgname=${pkgname%-git}
+pkgver=r79.6c0be4d
+pkgrel=1
+pkgdesc="Dependency graph of installed packages on your wallpaper."
+url="http://github.com/Kharacternyk/${_pkgname}"
+arch=('any')
+license=('GPL-3')
+depends=('graphviz' 'pacman-contrib')
+optdepends=('feh: wallpaper setting using feh'
+ 'hsetroot: wallpaper setting using hsetroot'
+ 'imagemagick: DE integration'
+ 'xorg-xdpyinfo: DE integration')
+makedepends=('git')
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Kharacternyk/${_pkgname}.git#branch=master")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}/pacwall.sh" "${pkgdir}/usr/bin/pacwall"
+ install -Dm644 "${srcdir}/${_pkgname}/README.rst" "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}