summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkitsunyan2018-03-11 00:51:44 +0300
committerkitsunyan2018-03-11 00:51:44 +0300
commite30e5d8361f6d43e19628590ee7e8313668753d2 (patch)
treec204dd452eeca3666670511683e42bd88c4a14ab /PKGBUILD
downloadaur-e30e5d8361f6d43e19628590ee7e8313668753d2.tar.gz
addpkg: pakku 0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7d1c0f079a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: kitsunyan <kitsunyan@inbox.ru>
+
+pkgname=pakku
+pkgver=0.1
+pkgrel=1
+pkgdesc='Pacman wrapper with AUR support'
+arch=('x86_64')
+url="https://github.com/kitsunyan/$pkgname"
+license=('GPL3')
+depends=('libcurl.so' 'git')
+makedepends=('nim')
+backup=('etc/pakku.conf')
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('aa3a6f5a78b005268580b8b0feae37db8612b7e4e9492fbd0c8dd2a3d27d539e')
+
+build() {
+ local addargs=()
+ grep -Fxq debug <<< "`printf '%s\n' "${options[@]}"`" &&
+ addargs=(NIM_TARGET='debug' NIM_OPTIMIZE='none')
+
+ cd "$srcdir/$pkgname-$pkgver"
+ make "${addargs[@]}" NIM_CACHE_DIR='../nimcache' PREFIX='/usr'
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX='/usr' DESTDIR="$pkgdir" install
+}