summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMrViK2018-07-18 00:41:05 +0200
committerMrViK2018-07-18 00:41:05 +0200
commit2452997d16098e44889b26a596b45b5f3414f52b (patch)
tree8a0cd202b1449ef54ed40b26e9fe0e24104b814e /PKGBUILD
downloadaur-2452997d16098e44889b26a596b45b5f3414f52b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3f73d42f9b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=pakku-gui
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="GTK frontend for pakku"
+arch=("any") # If pakku and python can be installed, this too
+url="https://gitlab.com/mrvik/pakku-gui"
+license=("GPL2")
+depends=("python" "python-gobject" "gtk3" "pakku")
+source=("https://gitlab.com/mrvik/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar")
+provides=($pkgname)
+conflicts=($pkgname-git)
+sha256sums=("9ca9afb4095d09a39377b98486bb93c97c4dd07de6c5482e7f9e55fe0a32432f")
+
+package(){
+ _libdir=$pkgdir/usr/lib/$pkgname
+ _applications=$pkgdir/usr/share/applications
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$_libdir" "$_applications" "$pkgdir/usr/bin"
+ cp *.py "$_libdir"
+ cp "$pkgname.desktop" "$_applications"
+ chmod +x "$_libdir/main.py"
+ ln -s "/usr/lib/$pkgname/main.py" "$pkgdir/usr/bin/$pkgname"
+}