summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMrViK2018-07-18 00:35:54 +0200
committerMrViK2018-07-18 00:35:54 +0200
commitc6292d47a5bfab1d12f14adb43f9d3d299c53fd7 (patch)
treede8c13f67996704733794a52806b873550d67332 /PKGBUILD
downloadaur-c6292d47a5bfab1d12f14adb43f9d3d299c53fd7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76942a545492
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_pkgname=pakku-gui
+pkgname=$_pkgname-git
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="GTK frontend for pakku"
+arch=("any") # If pakku and python can be installed, this too
+url="https://gitlab.com/mrvik/$_pkgname"
+license=("GPL2")
+depends=("python" "python-gobject" "gtk3" "pakku")
+makedepends=("git")
+source=("git+https://gitlab.com/mrvik/$_pkgname.git")
+provides=($_pkgname)
+conflicts=($_pkgname)
+sha256sums=('SKIP')
+pkgver(){
+ cd $_pkgname
+ git describe --tags|sed 's+-+.+g'
+}
+
+package(){
+ _libdir=$pkgdir/usr/lib/$_pkgname
+ _applications=$pkgdir/usr/share/applications
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$_libdir" "$_applications" "$pkgdir/usr/bin"
+ cp *.py "$_libdir"
+ cp "$_pkgname.desktop" "$_applications"
+ chmod +x "$_libdir/main.py"
+ ln -s "/usr/lib/$_pkgname/main.py" "$pkgdir/usr/bin/$_pkgname"
+}