summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-10-03 15:41:46 +1300
committercaltlgin2020-10-03 15:41:46 +1300
commit015147bd390284600b08517954e7ec0af705544d (patch)
tree0005afa1acc0ee8b36d592799ee9dc80bc999df2 /PKGBUILD
downloadaur-015147bd390284600b08517954e7ec0af705544d.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f255544c7740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='palaura'
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='Find any words definition with this handy dictionary'
+arch=('x86_64')
+url='https://github.com/lainsce/palaura/'
+license=('GPL3')
+depends=('granite' 'gtksourceview3')
+makedepends=('meson' 'vala')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('555c1e06981b98280e806504bc9b31e93ac501e4e4845c301982207a60d9daae')
+
+build() {
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
+}
+
+# vim: ts=2 sw=2 et: