summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-08-16 20:44:14 +0100
committerWorMzy Tykashi2018-08-16 20:44:14 +0100
commit64dad0fe550a3aff8302d61d51162a139a202a65 (patch)
treedd38fab68ace8c4e6c5089071c16b625bb8af42f /PKGBUILD
parent318676b0365ee908f084595b1f3648ee75a0384b (diff)
downloadaur-64dad0fe550a3aff8302d61d51162a139a202a65.tar.gz
Updated to 28.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 8 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21b1f18160d8..a8b816970cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=27.9.4
+pkgver=28.0.0
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -11,28 +11,26 @@ url="https://www.palemoon.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
-makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm'
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gconf'
'libpulse' 'gcc5')
optdepends=('libpulse: PulseAudio audio driver'
- 'hunspell: spell checker and morphological analyzer'
- 'hyphen: library for hyphenation and justification'
'ffmpeg: various video and audio support')
-source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
+source=(git+"https://github.com/MoonchildProductions/UXP#tag=PM${pkgver}_Release"
mozconfig.in)
md5sums=('SKIP'
- '3b1d2eff90892a99ff6a0e078b35a839')
+ '24969676f8b0228701bfb87e05b4526e')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
- sed -i 's#xlocale#locale#' Pale-Moon/intl/icu/source/i18n/digitlst.cpp
+ sed -i 's#xlocale#locale#' UXP/intl/icu/source/i18n/digitlst.cpp
}
build() {
- cd Pale-Moon
+ cd UXP
# gcc5 doesn't understand the -fno-plt flag, strip it out of C{,XX}FLAGS
export CFLAGS="${CFLAGS//-fno-plt/}"
- export CXXFLAGS="${CFLAGS//-fno-plt/}"
+ export CXXFLAGS="${CXXFLAGS//-fno-plt/}"
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZCONFIG="$srcdir/mozconfig"
@@ -58,16 +56,6 @@ package() {
install -Dm644 palemoon/browser/icons/mozicon128.png \
"$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
- # use system-provided dictionaries
- rm -rf "$pkgdir"/usr/lib/$pkgname/{dictionaries,hyphenation}
- ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
- # avoid duplicate binaries
- # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- #ln -sf palemoon "$pkgdir/usr/lib/$pkgname/palemoon-bin"
- rm -f "$pkgdir/usr/lib/$pkgname/palemoon-bin"
-
# install desktop file
- install -Dm644 "$srcdir/Pale-Moon/browser/branding/official/palemoon.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/UXP/application/palemoon/branding/official/palemoon.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}