summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-09-01 13:01:25 +0100
committerWorMzy Tykashi2015-09-01 13:01:25 +0100
commitc178ec0217bd87b0c8e2fe018e2970d32488286c (patch)
tree48e2009cc9e73af9fde493f5f44663e8280733a0 /PKGBUILD
parentbe5a3595af37e8b34f707e5b655b701ff5024708 (diff)
downloadaur-c178ec0217bd87b0c8e2fe018e2970d32488286c.tar.gz
Split build function -> prepare
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 712fb52be7ef..219828c356f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,24 +24,26 @@ md5sums=('SKIP'
'32231f6e6a532021fd04c6d7b32f4270'
'9ff0a5a4cfa930148cb96612bed4fe09')
+prepare() {
+ sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
+ cd Pale-Moon
+
+ chmod -R +x build/autoconf/* python/*
+ find . -name '*.sh' -exec chmod +x {} \;
+}
+
build() {
- export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
- export MOZCONFIG="$srcdir/mozconfig"
- echo MOZBUILD_STATE_PATH=$MOZBUILD_STATE_PATH
- echo MOZCONFIG=$MOZCONFIG
- sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
-
- cd "$srcdir/Pale-Moon"
- chmod -R +x build/autoconf/* python/*
- find . -name '*.sh' -exec chmod +x {} \;
+ cd Pale-Moon
- CPPFLAGS="$CPPFLAGS -O2"
- python2 mach build || echo "Next =>"
- python2 mach build
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MOZCONFIG="$srcdir/mozconfig"
+ export CPPFLAGS="$CPPFLAGS -O2"
+ python2 mach build || echo "Next =>"
+ python2 mach build
}
package() {
- cd "$srcdir/pmbuild"
+ cd pmbuild
make package
cd dist
install -d "$pkgdir"/usr/{bin,lib}