summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPavan Rikhi2018-11-06 17:32:18 -0500
committerPavan Rikhi2018-11-06 17:32:18 -0500
commitc932f75e559623568af854a9edc793b60a4b70da (patch)
tree838aeb91bf46f7b383504d685182a59463f6dab7 /PKGBUILD
parent26450461d742ab54fbe581d5a70569185c9d1b50 (diff)
downloadaur-c932f75e559623568af854a9edc793b60a4b70da.tar.gz
Fix Version Numbering
Add the commit number instead of improperly relying on the commit hash.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25aad009707b..f647ed461c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Forked from palemoon PKGBUILD by WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: artiom <a.mv at gmx dot fr>
pkgname=palemoon-git
-pkgver=28.1.0a1+eb2016063
+pkgver=28.2.0a1+r423.ga0a37ffd4
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency (git version)"
arch=('i686' 'x86_64')
@@ -26,7 +26,7 @@ md5sums=('SKIP'
pkgver() {
cd UXP
- echo $(cat application/palemoon/config/version.txt)"+"$(git rev-parse --short HEAD)
+ echo $(cat application/palemoon/config/version.txt)"+"$(git describe --long | sed 's/^[^-]*-/r/;s/-/./g')
}
prepare() {