summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Parnell2017-02-05 02:42:33 -0600
committerMatt Parnell2017-02-05 02:42:33 -0600
commite0c4821fd53a7ff550bba1e700d5a8b773ea6292 (patch)
treeb10664aeafedc9eaaa9381e0164c1c129d636672 /PKGBUILD
parent649e1fec1abb32105e1fa0b796024837fbc0d402 (diff)
downloadaur-e0c4821fd53a7ff550bba1e700d5a8b773ea6292.tar.gz
tidy up some things
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdadbba9dbe8..f3b3c4c3dd3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Forked from palemoon PKGBUILD by WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: artiom <a.mv at gmx dot fr>
pkgname=palemoon-git
-pkgver=27.1.0b2+5adfb550f
+pkgver=27.2.0a1+dfe35096e
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency (git version)"
arch=('i686' 'x86_64')
url="http://www.palemoon.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'alsa-lib')
- makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libpulse' 'gcc5')
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libpulse' 'gcc5')
optdepends=('networkmanager: Location detection via available WiFi networks'
'libpulse: PulseAudio audio driver'
'hunspell: spell checker and morphological analyzer'
@@ -24,8 +24,8 @@ source=(git+"https://github.com/MoonchildProductions/Pale-Moon"
md5sums=('SKIP'
'95d212604b6c8354f9e255db5c3ce0ea'
'32231f6e6a532021fd04c6d7b32f4270'
- 'df0b183564a8a554a66311f403cc4ee8')
-
+ 'e0c0ea868b019c2d83cec196d600e085')
+
pkgver() {
cd Pale-Moon
echo $(cat browser/config/version.txt)"+"$(git rev-parse --short HEAD)
@@ -44,12 +44,12 @@ build() {
patch -Np0 -i ../rhbz-966424.patch
- export CC="gcc-5"
- export CXX="g++-5"
+ export CC=gcc-5
+ export CXX=g++-5
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZCONFIG="$srcdir/mozconfig"
- export CPPFLAGS="$CPPFLAGS -O2 -march=native -mtune=native"
- export LDFLAGS="$LDFLAGS -Wl,-O1,--sort-common,--as-needed,-z,relro"
+ export CPPFLAGS="$CPPFLAGS -O3 -msse2 -mfpmath=sse -march=native -mtune=native"
+ export LDFLAGS="$LDFLAGS -Wl,-z,norelro,-O3,--sort-common,--as-needed,--relax,-z,combreloc,-z,global,--no-omagic"
python2 mach build || echo "Next =>"
python2 mach build
}