summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-09-14 23:56:24 +0200
committerMichal Wojdyla2021-09-14 23:56:24 +0200
commitb837e519188c7c965e8a947dc60c00741eedfab4 (patch)
tree619dfd85a48d6c37b11ec783702b172dba5bec32 /PKGBUILD
parent79c3fb7a2bc299c5d8eaa37b622eb435db428e8b (diff)
downloadaur-b837e519188c7c965e8a947dc60c00741eedfab4.tar.gz
update to 29.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0a84daf5182..0cbc0092207b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,7 @@
# Contributor: American_Jesus
pkgname=palemoon-gtk3
_pkgname=palemoon
-_repo=Pale-Moon
-pkgver=29.4.0.2
-# Commit can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/releases
-_commit=951553c0a4
+pkgver=29.4.1
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -22,26 +19,16 @@ makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm'
'libpulse' 'gcc10')
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
-source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
- git+"https://repo.palemoon.org/MoonchildProductions/UXP"
+source=("http://archive.palemoon.org/source/palemoon-${pkgver}-source.tar.xz"
mozconfig.in)
-sha1sums=('SKIP'
- 'SKIP'
+sha1sums=('e666ad085dbfd52558424ea9aa1cf0aa292c9388'
'f3cc0b20fd66066b0cb936a5f3f54b1145da1bab')
-validpgpkeys=('3059E09144F56804F0FBF4E126B40624BDBFD9F3'
- '3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
- cd ${_repo}
- git submodule init
- git config submodule.platform.url "${srcdir}/UXP"
- git submodule update
}
build() {
- cd ${_repo}
-
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CPPFLAGS="${CPPFLAGS} -O2 -Wno-format-overflow"
@@ -67,5 +54,5 @@ package() {
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgname}.png"
# install desktop file
- install -Dm644 "${srcdir}/${_repo}/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${srcdir}/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}