summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:04:37 +0200
committerM0Rf302015-06-17 16:04:37 +0200
commit2221eccba7caab2c326ee1272d4a1673f363af48 (patch)
tree9708cf0ae5efee88690e4deac12365775ebdf6ea /PKGBUILD
downloadaur-2221eccba7caab2c326ee1272d4a1673f363af48.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ac0cb6b606f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: M0Rf30
+# Contributor: Carlos RH Ruiz <ruizh.cj@gmail.com>
+
+pkgname=pam-face-authentication
+pkgver=0.3
+pkgrel=7
+pkgdesc="PAM face auth"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/pam-face-authentication"
+license=('GPL')
+depends=('pam' 'opencv' 'libx11' 'qt4')
+makedepends=('cmake')
+source=('http://pam-face-authentication.googlecode.com/files/pam-face-authentication-0.3.tar.gz')
+
+build() {
+cd "$srcdir"/${pkgname}-$pkgver
+
+ rm cmake/modules/FindOpenCV.cmake
+ cp /usr/share/opencv/OpenCVConfig.cmake cmake/modules
+ sed -i 's/OPENCV_LIBRARIES/OpenCV_LIBS/g' CMakeLists.txt
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4 .
+}
+
+package() {
+cd ${srcdir}/${pkgname}-$pkgver
+make || return 1
+make DESTDIR="$pkgdir/" install || return 1
+}
+
+md5sums=('5ef71bcf4bdebd2ee7216387ef17fc27')