summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpancho horrillo2020-11-13 06:26:02 +0100
committerpancho horrillo2020-11-13 06:57:30 +0100
commit0ec4a77bdc2573a22bcd62c50ffe5869195489e1 (patch)
treeb6176c6d2635bf878cf870e817642f9585475953 /PKGBUILD
parentcb4ed823ece6b3316a7b4103135dec8d1711473c (diff)
downloadaur-pam_ssh.tar.gz
Fix GCC10 incompatibility via patch, drop old code
Thanks a bunch to Jerome Benoît, who kindly let me know¹ that the GCC10 incompatibility issue had been fixed² by Jeroen Roovers jer@gentoo.org at Gentoo. I've applied the patch² and removed the relaxing parameter to GCC. Also, I've dropped the install script, which at this point is ancient history. Fix indent style for sha512sums array. ¹: https://sourceforge.net/p/pam-ssh/bugs/18/#e743 ²: https://709312.bugs.gentoo.org/attachment.cgi?id=634046
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03aaf0ce41ec..31e6abe51241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,32 @@
pkgname=pam_ssh
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc='PAM module providing single sign-on behavior for SSH.'
arch=('i686' 'x86_64')
url='http://pam-ssh.sourceforge.net/'
license=('custom')
depends=('pam' 'openssl' 'openssh')
options=('!libtool')
-install="$pkgname.install"
source=(
+ "fix-common.patch::https://709312.bugs.gentoo.org/attachment.cgi?id=634046"
"https://sourceforge.net/projects/pam-ssh/files/pam_ssh/$pkgver/pam_ssh-$pkgver.tar.xz"{,.asc}
)
-sha512sums=('e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895'
+sha512sums=('064036f99f88c142d585b0825bf6c20d10d40fb1ca06ad09be51804fd49cb2dfcbee7633a9ae5237e54b0c9aa20b2ef687fea2fa883e3022b352c78c25fc4d3f'
+ 'e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895'
'SKIP')
validpgpkeys=(
'501B088D8485568B87BB62BE180F6A5B3EDE742E' # Wolfgang Rosenauer
)
+prepare () {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir/fix-common.patch"
+}
+
build () {
cd "$srcdir/$pkgname-$pkgver"
- CFLAGS="$CFLAGS -fcommon" ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
+ ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
make
}