summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLibrewish2020-08-25 15:21:15 +0530
committerLibrewish2020-08-25 15:21:15 +0530
commitb62843f446bdc2dd86aca5c899925795f932322f (patch)
tree81f05c29fbc46a53abc635706d50d89b261ff847 /PKGBUILD
downloadaur-b62843f446bdc2dd86aca5c899925795f932322f.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 83 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09ea8a993051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Contributor: Zeph <zeph33@gmail.com>
+# Maintainer: Librewish <librewish@gmail.com>
+# https://gitlab.manjaro.org/packages/extra/pamac
+ENABLE_FLATPAK=1
+ENABLE_SNAPD=1
+ENABLE_APPINDICATOR=1
+ENABLE_GNOME=0
+
+pkgname=pamac-all
+pkgver=9.5.8
+pkgrel=1
+_pkgfixver=$pkgver
+
+pkgdesc="A Gtk3 frontend for libalpm (everything in one package - snap, flatpak, appindicator)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://gitlab.manjaro.org/applications/pamac"
+license=('GPL3')
+depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22'
+ 'libnotify' 'desktop-file-utils' 'pacman>=5.2' 'gnutls>=3.4' 'git'
+ 'appstream-glib' 'archlinux-appstream-data')
+
+optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome')
+makedepends=('gettext' 'itstool' 'vala>=0.45' 'meson' 'ninja' 'gobject-introspection' 'xorgproto')
+backup=('etc/pamac.conf')
+conflicts=('pamac' 'pamac-gtk' 'pamac-cli' 'pamac-common' 'pamac-aur' 'pamac-aur-git')
+provides=("pamac=$pkgver-$pkgrel")
+options=(!emptydirs)
+install=pamac.install
+source=(
+ "pamac-$pkgver.tar.gz::$url/-/archive/v$pkgver/pamac-v$pkgver.tar.gz"
+# "https://gitlab.manjaro.org/applications/pamac/-/commit/83ac80d7.patch"
+ )
+sha256sums=('7bd05f1dbb815ebddcfca85e54c873a0d376e55797ca58e2ad11e815962aca29')
+define_meson=''
+if [ "${ENABLE_FLATPAK}" = 1 ]; then
+ depends+=('flatpak')
+ define_meson+=' -Denable-flatpak=true'
+ conflicts+=('pamac-flatpak-plugin')
+fi
+
+if [ "${ENABLE_SNAPD}" = 1 ]; then
+ depends+=('snapd' 'snapd-glib')
+ define_meson+=' -Denable-snap=true'
+ provides+=('pamac-snap-plugin')
+ conflicts+=('pamac-snap-plugin')
+fi
+
+if [ "${ENABLE_APPINDICATOR}" = 1 ]; then
+ depends+=('libappindicator-gtk3')
+ define_meson+=' -Denable-appindicator=true'
+ provides+=('pamac-tray-appindicator' )
+ conflicts+=('pamac-tray-appindicator' 'pamac-aur-tray-appindicator-git')
+fi
+
+if [ "${ENABLE_GNOME}" = 1 ]; then
+ define_meson+=' -Denable-fake-gnome-software=true'
+ provides+=("pamac-gnome-integration" 'gnome-software')
+ conflicts+=("pamac-gnome-integration" 'gnome-software')
+fi
+
+prepare() {
+ cd "$srcdir/pamac-v$pkgver"
+ # adjust version string
+ sed -i -e "s|\"$_pkgfixver\"|\"$pkgver-$pkgrel\"|g" src/version.vala
+}
+
+build() {
+ cd "$srcdir/pamac-v$pkgver"
+ mkdir -p builddir
+ cd builddir
+ meson --buildtype=release \
+ --prefix=/usr \
+ --sysconfdir=/etc $define_meson
+ # build
+ ninja
+}
+
+package() {
+ cd "$srcdir/pamac-v$pkgver/builddir"
+
+ DESTDIR="$pkgdir" ninja install
+}
+# vim:set ts=2 sw=2 et: