summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2017-10-12 10:55:13 +0200
committerFrederic Bezies2017-10-12 10:55:13 +0200
commit7bd2b735acdad257c2fed951936d415bec6ea8c0 (patch)
treedd423c6b2f6f4903ea5381302b8b95952bd5487f /PKGBUILD
parent1244d4accb97cce8d85c536a74072e88d2f05c2f (diff)
downloadaur-7bd2b735acdad257c2fed951936d415bec6ea8c0.tar.gz
6.0.4 update + meson build migration + some tweaks for appindicator package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 32 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1355541c78f1..589062970923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Zeph <zeph33@gmail.com>
# Based on the PKGBUILD created by Zeph <zeph33@gmail.com>
-pkgname=('pamac-aur-git' 'pamac-aur-tray-appindicator-git')
+pkgname=('pamac-aur-git' 'pamac-aur-tray-appindicator-git')
_pkgname=pamac
-pkgver=v6.0.3.r2.g78b8257
+pkgver=v6.0.4.r3.gb440fa1
_pkgver=6.0
pkgrel=1
pkgdesc="A Gtk3 frontend for libalpm - git version"
@@ -13,9 +13,9 @@ url="https://github.com/manjaro/pamac"
license=('GPL3')
depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22' 'libnotify' 'desktop-file-utils' 'pacman>=5.0' 'pacman<5.1' 'gnutls>=3.4' 'appstream-glib' 'archlinux-appstream-data' 'libappindicator-gtk3')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.'
- 'pamac-tray-appindicator: tray icon for KDE')
-makedepends=('gettext' 'itstool' 'vala>=0.36')
+ 'lxsession: needed for authentification in Xfce, LXDE etc.')
+ #'pamac-tray-appindicator-git: tray icon for KDE')
+makedepends=('gettext' 'itstool' 'vala>=0.36' 'meson' 'ninja')
options=(!emptydirs)
source=(git+https://github.com/manjaro/pamac.git)
@@ -35,34 +35,46 @@ prepare() {
build() {
cd "$_pkgname"
-
- # build
- make all
+ rm -rf _build
+ /usr/bin/meson _build --prefix=/usr --sysconfdir=/etc
+ ninja -C _build
}
package_pamac-aur-git() {
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.'
- 'pamac-dev-tray-appindicator-git: tray icon for KDE')
- conflicts=('pamac' 'pamac-aur')
+ 'lxsession: needed for authentification in Xfce, LXDE etc.')
+ #'pamac-dev-tray-appindicator-git: tray icon for KDE')
+ conflicts=('pamac' 'pamac-aur' 'pamac-aur-tray-appindicator-git')
provides=('pamac' 'pamac-aur')
backup=('etc/pamac.conf')
replaces=('pamac-aur')
install=pamac.install
cd "$_pkgname"
- make prefix="$pkgdir"/usr sysconfdir="$pkgdir"/etc install
- # delete timer no pamac-mirror for Arch Linux
- rm "$pkgdir"/etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer
+ env DESTDIR="$pkgdir" ninja -C _build install
}
package_pamac-aur-tray-appindicator-git() {
- pkgdesc="Tray icon using appindicator which feets better in KDE - git version"
- depends=('pamac-aur-git' 'libappindicator-gtk3')
- conflicts=('pamac-tray-appindicator')
- provides=('pamac-tray-appindicator')
+ pkgdesc="Pamac and tray icon using appindicator which feets better in KDE - git version"
+ depends=('libappindicator-gtk3')
+ conflicts=('pamac-aur-git pamac-aur pamac-tray-appindicator')
+ provides=('pamac-aur pamac-tray-appindicator')
cd "$_pkgname"
- make use_appindicator=true
- make prefix="$pkgdir"/usr sysconfdir="$pkgdir"/etc install_pamac-tray-appindicator
+
+ # Adding a modified meson_options file to enable appindicator build
+ # -> set enable-appindicator to true !
+ # I know it is a dirty workaround :(
+ # Until a new revision, pamac-aur and pamac-aur-tray-appindicator-git will
+ # enter in conflict... Thanks to meson build process ?!
+
+ rm -rf _build
+ echo "option('enable-appindicator', type : 'boolean', value : true, description : 'tray icon using appindicator')" >> meson_options.txt
+ /usr/bin/meson _build --prefix=/usr --sysconfdir=/etc
+ ninja -C _build
+ env DESTDIR="$pkgdir" ninja -C _build install
+
+ # Copying missing desktop file
+ install -Dm644 $srcdir/$_pkgname/data/applications/pamac-tray-appindicator.desktop $pkgdir/usr/share/applications/
}
# vim:set ts=2 sw=2 et:
+