summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2017-10-17 22:57:00 +0200
committerFrederic Bezies2017-10-17 22:57:00 +0200
commit82ee864882a2ab79ee4864f508556fc25a152917 (patch)
treece2cfce40ab57bd177f3c6b81797bcfe4c8dead3 /PKGBUILD
parentbc49c3a15a7e43de1b13d72656d8844ceae19a5f (diff)
downloadaur-82ee864882a2ab79ee4864f508556fc25a152917.tar.gz
synchronized with manjaro PKGBUILD, thanks to scachemaille comment
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 22 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efd2fe7ec7fe..f26340ca36cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('pamac-aur-git' 'pamac-aur-tray-appindicator-git')
_pkgname=pamac
-pkgver=v6.1.1
+pkgver=v6.1.1.r1.g7ae235f
_pkgver=6.1
pkgrel=1
pkgdesc="A Gtk3 frontend for libalpm - git version"
@@ -13,8 +13,7 @@ url="https://github.com/manjaro/pamac"
license=('GPL3')
depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22' 'libnotify' 'desktop-file-utils' 'pacman>=5.0' 'pacman<5.1' 'gnutls>=3.4' 'appstream-glib' 'archlinux-appstream-data' 'libappindicator-gtk3')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.')
- #'pamac-tray-appindicator-git: tray icon for KDE')
+ 'lxsession: needed for authentification in Xfce, LXDE etc.')
makedepends=('gettext' 'itstool' 'vala>=0.36' 'meson' 'ninja')
options=(!emptydirs)
@@ -35,45 +34,37 @@ prepare() {
build() {
cd "$_pkgname"
- rm -rf _build
- /usr/bin/meson _build --prefix=/usr --sysconfdir=/etc
- ninja -C _build
+ mkdir -p builddir
+ cd builddir
+ meson --prefix=/usr --sysconfdir=/etc -Denable-appindicator=true
+
+ # build
+ ninja
}
package_pamac-aur-git() {
- optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.')
- #'pamac-dev-tray-appindicator-git: tray icon for KDE')
- conflicts=('pamac' 'pamac-aur' 'pamac-aur-tray-appindicator-git')
- provides=('pamac' 'pamac-aur')
+ optdepends=('pamac-tray-appindicator-git: tray icon for KDE')
backup=('etc/pamac.conf')
replaces=('pamac-aur')
install=pamac.install
cd "$_pkgname"
- env DESTDIR="$pkgdir" ninja -C _build install
+ cd builddir
+ DESTDIR="$pkgdir" ninja install
+ # enable systemd timer
+ mkdir -p "$pkgdir/etc/systemd/system/multi-user.target.wants"
+ ln -sf "/usr/lib/systemd/system/pamac-cleancache.timer" "$pkgdir/etc/systemd/system/multi-user.target.wants"
+ ln -sf "/usr/lib/systemd/system/pamac-mirrorlist.timer" "$pkgdir/etc/systemd/system/multi-user.target.wants"
+ # remove pamac-tray-appindicator
+ rm "$pkgdir/usr/bin/pamac-tray-appindicator"
+ rm "$pkgdir/etc/xdg/autostart/pamac-tray-appindicator.desktop"
}
package_pamac-aur-tray-appindicator-git() {
- pkgdesc="Pamac and tray icon using appindicator which feets better in KDE - git version"
- depends=('libappindicator-gtk3')
- conflicts=('pamac-aur-git pamac-aur pamac-tray-appindicator')
- provides=('pamac-aur pamac-tray-appindicator')
+ pkgdesc="Tray icon using appindicator which feets better in KDE - git version"
+ depends=('pamac-aur-git' 'libappindicator-gtk3')
cd "$_pkgname"
-
- # Adding a modified meson_options file to enable appindicator build
- # -> set enable-appindicator to true !
- # I know it is a dirty workaround :(
- # Until a new revision, pamac-aur and pamac-aur-tray-appindicator-git will
- # enter in conflict... Thanks to meson build process ?!
-
- rm -rf _build
- echo "option('enable-appindicator', type : 'boolean', value : true, description : 'tray icon using appindicator')" >> meson_options.txt
- /usr/bin/meson _build --prefix=/usr --sysconfdir=/etc
- ninja -C _build
- env DESTDIR="$pkgdir" ninja -C _build install
-
- # Copying missing desktop file
- install -Dm644 $srcdir/$_pkgname/data/applications/pamac-tray-appindicator.desktop $pkgdir/usr/share/applications/
+ install -Dm755 "builddir/src/pamac-tray-appindicator" "$pkgdir/usr/bin/pamac-tray-appindicator"
+ install -Dm644 "data/applications/pamac-tray-appindicator.desktop" "$pkgdir/etc/xdg/autostart/pamac-tray-appindicator.desktop"
}
# vim:set ts=2 sw=2 et: