summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsudoBash4182019-07-07 04:44:31 -0600
committersudoBash4182019-07-07 04:44:31 -0600
commit9dcb358a6708c5fd9fc103d8496198d03959c0f5 (patch)
treee47c67d81e0c33ffb217e85bf172afec0c8c7dd1 /PKGBUILD
parent755d05c518a4c32be3593e6b95035d1a24b3768c (diff)
downloadaur-9dcb358a6708c5fd9fc103d8496198d03959c0f5.tar.gz
Update to 7.0.0; switch to meson build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a987e4aa5d54..b42c4b268220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Thomas Bork <sudobash418@gmail.com>
pkgname=pamac-classic
-pkgver=6.7.3
+pkgver=7.0.0
pkgrel=1
pkgdesc="A Gtk3 frontend for libalpm - classic version"
arch=('x86_64')
url="https://git.cromer.cl/cromer/pamac-classic"
license=('GPL3')
depends=('curl' 'libsoup' 'polkit' 'pacman' 'libnotify' 'vte3')
-makedepends=('vala' 'cmake' 'gettext' 'gobject-introspection')
+makedepends=('vala' 'meson' 'gettext' 'gobject-introspection')
optdepends=('polkit-gnome: needed for authentication in Cinnamon, Gnome'
'mate-polkit: needed for authentication in MATE'
'lxsession: needed for authentication in Xfce, LXDE etc.')
@@ -16,20 +16,21 @@ conflicts=('pamac' 'pamac-aur')
provides=('pamac' 'pamac-aur')
install=pamac-classic.install
-source=("pamac-classic-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('72203ce9ce5faadd3bda843f4558216a8dd7ada46bf2b8a30893d35254a28c1f')
+source=("pamac-classic-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz")
+sha256sums=('f7e663107bcc8cf0da057459afdb7fbc4f254c2c9fba6813e2706454be9c7d9b')
build() {
- cd "${srcdir}/pamac-classic"
+ cd "${srcdir}/${pkgname}"
+ mkdir build
- # configure with AUR - add --disable-aur to disable AUR support
- ./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc --disable-icon-update
+ # configure with AUR - add -DDISABLE_AUR=true to disable AUR support
+ meson --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc . build
- # build
- make
+ # build
+ ninja -C build
}
package() {
- cd "${srcdir}/pamac-classic"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}"
+ DESTDIR="$pkgdir" ninja -C build install
}