summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2020-12-25 16:25:23 +0100
committerJose Riha2020-12-25 16:25:23 +0100
commit224f1d925c74a9243cd08efb21689194d9a55555 (patch)
tree5d189d5303e0cbf6ea651de1b8a251419ea799fb /PKGBUILD
parentbe2aaa320ebd53b68b16237ee5cd5482c9dd2dd2 (diff)
downloadaur-224f1d925c74a9243cd08efb21689194d9a55555.tar.gz
Fix lib64 directory conflict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10e0a056e6a9..4325885869cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: David Radford <croxis gmail com>
+# Jose Riha: Jose Riha <jose 1711 gmail com>
+# Contributor: David Radford <croxis gmail com>
# Contributor: Robin Baumgartner <robin@baumgartners.ch>
# Contributor: Tucos <baspape@gmail.com>
pkgname=panda3d
pkgver=1.10.7
-pkgrel=1
+pkgrel=2
pkgdesc="A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d."
url="http://www.panda3d.org"
arch=('i686' 'x86_64')
@@ -61,10 +62,16 @@ optdepends=(# Pretty much required
install='panda3d.install'
source=("https://github.com/panda3d/panda3d/archive/v$pkgver.tar.gz"
- 'panda3d.install')
+ 'panda3d.install'
+ 'libdir_fix.patch')
JOBS=$(nproc)
+prepare() {
+ cd "$srcdir/panda3d-$pkgver/makepanda"
+ patch -p0 -i "$srcdir/libdir_fix.patch"
+}
+
build() {
cd "$srcdir/panda3d-$pkgver"
python makepanda/makepanda.py --everything --no-opencv --no-opencv --no-maya2012 --no-fmodex --no-gles --no-gles2 --no-openssl --no-egl ${PANDAFLAGS} --threads ${BUILD_THREADS:-$JOBS}
@@ -79,4 +86,5 @@ package() {
sha256=('a8e438d4a13ac8c81b80d288326617b3'
'057269173f3c1987953302519bc744fa')
md5sums=('d53383267e7908cf54cb46d3eefd66d2'
- '057269173f3c1987953302519bc744fa')
+ '057269173f3c1987953302519bc744fa'
+ '44d5cd0d121ec966f52d6ca00fdf81eb')