summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThor K. H2020-05-04 13:08:46 +0200
committerThor K. H2020-05-04 13:08:46 +0200
commit6664e7ecbe54842aef420cedfc55f99d4ae66b86 (patch)
treeb205d3fdea4d45a25e12d7cdffa15183d8211e48 /PKGBUILD
downloadaur-6664e7ecbe54842aef420cedfc55f99d4ae66b86.tar.gz
Fix folder name
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b284b4f2b8e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Thor K. Høgås <thor@roht.no>
+pkgname=pandoc-ac-git
+_pkgname=pandoc-ac
+pkgver=0.2.0.r5.56a3957
+pkgrel=1
+pkgdesc="Simple Pandoc filter for a clean syntax to LaTeX acronyms"
+arch=('x86_64')
+url="https://github.com/Enet4/pandoc-ac"
+license=('MIT' 'Apache')
+groups=()
+depends=()
+makedepends=('cargo')
+checkdepends=()
+optdepends=()
+provides=('pandoc-ac')
+conflicts=('pandoc-ac')
+backup=()
+source=("$_pkgname::git+https://github.com/Enet4/pandoc-ac.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release --locked --all-features
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
+}