summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2018-05-29 17:25:11 +0200
committerMaxime Gauduin2018-05-29 17:25:11 +0200
commit3e3dbe2e042f595187f41d119fd189aff5a6a1a7 (patch)
tree78883c2afd1c28f8d20cb965916a32872db5f073 /PKGBUILD
parent1fe2cb17d495ed68de0c89818719ab143dc7a715 (diff)
downloadaur-pantheon-geoclue2-agent-git.tar.gz
Switch to meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 5 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cce57d24fdfa..ddbdd5e595a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=pantheon-geoclue2-agent-git
-pkgver=r78.3546705
+pkgver=r103.1effca6
pkgrel=1
pkgdesc='Pantheon Geoclue2 Agent'
arch=('x86_64')
@@ -9,7 +9,7 @@ url='https://github.com/elementary/pantheon-agent-geoclue2'
license=('GPL3')
groups=('pantheon-unstable')
depends=('dbus-glib' 'glib2' 'glibc' 'gtk3' 'geoclue2')
-makedepends=('cmake' 'cmake-modules-elementary-git' 'git' 'intltool' 'vala')
+makedepends=('git' 'intltool' 'meson' 'vala')
provides=('pantheon-geoclue2-agent')
conflicts=('pantheon-geoclue2-agent')
source=('pantheon-geoclue2-agent::git+https://github.com/elementary/pantheon-agent-geoclue2.git')
@@ -21,30 +21,13 @@ pkgver() {
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-prepare() {
- cd pantheon-geoclue2-agent
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-}
-
build() {
- cd pantheon-geoclue2-agent/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBEXECDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='OFF'
- make
+ arch-meson pantheon-geoclue2-agent build
+ ninja -C build
}
package() {
- cd pantheon-geoclue2-agent/build
-
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: