summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFalko Galperin2021-07-16 01:24:36 +0200
committerFalko Galperin2021-07-16 01:24:36 +0200
commiteeb8b3d191b0eb727c7dd650c46a5efa59edbc30 (patch)
treed6bc8e2ffb4d6e0ce348e1d3ff90c4f5ab58dbeb /PKGBUILD
downloadaur-eeb8b3d191b0eb727c7dd650c46a5efa59edbc30.tar.gz
Initial commit for paper2remarkable AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec07326c9648
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Falko Galperin <dr (dot) asasteghof (at) gmail (dot) com>
+pkgname=paper2remarkable
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="Easily download an academic paper and send it to a reMarkable."
+arch=(any)
+url="https://github.com/GjjvdBurg/paper2remarkable"
+license=('MIT')
+# Note: While we have the choice between qpdf and pdftk,
+# python-pikepdf depends on qpdf anyway, so we use that here.
+depends=('python>=3.6.0' 'qpdf' 'ghostscript' 'poppler' 'rmapi' 'python-pikepdf>=2.9.0'
+'python-beautifulsoup4>=4.8' 'python-html2text>=2020.1.16' 'python-markdown>=3.1.1'
+'python-pdfplumber>=0.5' 'python-yaml>=5.1' 'python-readability-lxml>=0.7.1'
+'python-regex>=2018.11' 'python-requests>=2.21' 'python-titlecase>=0.12'
+'python-unidecode>=1.1' 'python-weasyprint>=51')
+makedepends=('python-setuptools')
+optdepends=('python-readabilipy: Improves output of web articles')
+changelog=$pkgname.changelog.md
+install=$pkgname.install
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=("845005b0beacc1d42f67271cc027e85ffc5224f992e3289d8c3b53523a226bbe")
+
+build() {
+ cd "$pkgname-$pkgver/"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ # move man page to directory specified by FHS guidelines
+ mkdir -p "$pkgdir/usr/share/"
+ mv "$pkgdir/usr/man" "$pkgdir/usr/share/man"
+}