summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFadeMind2016-06-03 18:57:30 +0200
committerFadeMind2016-06-03 18:57:30 +0200
commit83382a31b8600bb88b199f0248ffb19dbe0fc409 (patch)
tree161688eb17da886ec6548a8910e243fa7a44ca5a /PKGBUILD
downloadaur-83382a31b8600bb88b199f0248ffb19dbe0fc409.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71db1bc4018c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+pkgname=papirus-libreoffice-theme
+_commit=536bba5
+pkgver=20160601
+pkgrel=1
+pkgdesc="Papirus theme for LibreOffice"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
+arch=('any')
+license=('GPL')
+depends=('plasma-desktop')
+makedepends=('git' 'make')
+conflicts=('papirus-libreoffice-theme-git' 'libreoffice-papirus-theme' 'libreoffice-papirus-theme-git')
+optdepends=('libreoffice' 'libreoffice-fresh-rpm')
+options=('!strip')
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}