summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFadeMind2016-06-03 19:15:24 +0200
committerFadeMind2016-06-03 19:15:24 +0200
commit0202b1ea34edff4aaf07165eceb9216da9bc448d (patch)
treee2308ec0b59fa1f83d1d259012465d48f27cd872 /PKGBUILD
parent46586cb53938eaa7becb24bb661a8213f291f996 (diff)
downloadaur-0202b1ea34edff4aaf07165eceb9216da9bc448d.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5756478370e9..8c6d25a0f485 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
-# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+# Maintainer: FadeMind <fademind@gmail.com>
-_git=3f97691234d1688ad54b94d9b81f9ef181b0d8e9
-_repo=papirus-pack-kde
pkgname=papirus-plasma-theme
-pkgver=20151004
+_commit=f88f002 # 7 digits
+pkgver=20160603
pkgrel=1
-pkgdesc="Modified and adaptive Paper plasma theme for KDE"
+pkgdesc="Papirus plasma theme for KDE"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
arch=('any')
-url="https://github.com/varlesh/${_repo}"
-license=('CCPL:by-sa')
+license=('GPL')
+depends=('plasma-desktop')
+makedepends=('git' 'make')
+conflicts=('papirus-plasma-theme-git')
options=('!strip')
-source=("${_repo}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
-sha256sums=('87e2b1cbb0e08588a231d5c2638926de7ba566c5c0df81f4a897f95b54957f63')
+install="${pkgname}.install"
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
package() {
- install -d ${pkgdir}/usr/share/plasma/desktoptheme
- cp -r ${srcdir}/${_repo}-${_git}/plasma-themes/papirus* ${pkgdir}/usr/share/plasma/desktoptheme/
- install -D -m644 ${srcdir}/${_repo}-${_git}/plasma-themes/papirus/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
-} \ No newline at end of file
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}