summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrigorii Horos2015-08-15 15:43:16 +0300
committerGrigorii Horos2015-08-15 15:43:16 +0300
commitca9f569d36d07f8813c051e39f1850fc08c2dfdc (patch)
tree92b9daf045a7086c9332b04bb5f89a20f14640b2 /PKGBUILD
downloadaur-ca9f569d36d07f8813c051e39f1850fc08c2dfdc.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b08f72fdd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+
+_git=10391273ed3b7b56f98330db1efd8c1e51922bba # lastest commit 20150731
+_repo=papirus-pack-kde
+pkgname=papirus-plasma-theme
+pkgver=20150808
+pkgrel=1
+pkgdesc="Modified and adaptive Paper icon theme for KDE"
+arch=('any')
+url="https://github.com/varlesh/${_repo}"
+license=('CCPL:by-sa')
+options=('!strip')
+source=("${_repo}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
+sha256sums=('934b2d28a88c155f41702512e186be4cfd9d7bf1f2370be29bd32da0ec8b6e25')
+
+package() {
+ install -d ${pkgdir}/usr/share/plasma/desktoptheme
+ cp -r ${srcdir}/${_repo}-${_git}/plasma-themes/papirus* ${pkgdir}/usr/share/plasma/desktoptheme/
+ install -D -m644 ${srcdir}/${_repo}-${_git}/plasma-themes/papirus/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+} \ No newline at end of file