summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2020-05-20 21:36:39 +1000
committerJP-Ellis2020-05-20 21:36:39 +1000
commiteed6de4934e81e8d15ac6beef306d69dd0748e86 (patch)
tree03a2f6a653b3f8f4bd4a47afb8c7db910fa3833e /PKGBUILD
parentf4f5a2ca93d64df37dcd835a531a9fff72e4b552 (diff)
downloadaur-eed6de4934e81e8d15ac6beef306d69dd0748e86.tar.gz
Update to papis 0.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7329a6c6e870..1edd9e72644b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,42 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
-pkgver=0.9
-pkgrel=2
+pkgver=0.10
+pkgrel=1
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
url="https://github.com/papis/papis"
license=('GPL')
depends=('python'
+ 'python-requests'
+ 'python-filetype'
+ 'python-pyparsing'
'python-arxiv2bib'
+ 'python-pyaml'
+ 'python-chardet'
'python-beautifulsoup4'
+ 'python-colorama'
'python-bibtexparser'
- 'python-chardet'
'python-click'
- 'python-colorama'
- 'python-doi'
- 'python-filetype'
'python-habanero'
'python-isbnlib'
- 'python-lxml'
'python-prompt_toolkit'
- 'python-pyaml'
+ 'python-tqdm'
'python-pygments'
- 'python-pylibgen'
- 'python-pyparsing'
- 'python-requests'
- 'python-slugify'
'python-stevedore'
- 'python-tqdm'
+ 'python-doi'
+ 'python-typing_extensions'
+ 'python-lxml'
)
optdepends=('papis-rofi: integration with rofi')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
- "73e740b17d47e3ccddc72b58221f21a431b49d46.patch")
-sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42'
- '90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc'
- '0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d')
+ "b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch")
+sha256sums=('0668bba24c0ea159fd9f3497f8f26b1e27e8bc9d9f9a52c82ef28835ee4ec4d1'
+ '261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608')
noextract=()
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p 1 -i "${srcdir}/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
- patch -p 1 -i "${srcdir}/73e740b17d47e3ccddc72b58221f21a431b49d46.patch"
+ patch -p 1 < "${srcdir}/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch"
}
build() {