summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2019-12-23 10:23:52 +0800
committerJP-Ellis2019-12-23 10:23:52 +0800
commitfbea70214e1393c05326b4707e6c03772c19df23 (patch)
treeae894928e011d72f37e67fbe15522aaa6621a99a /PKGBUILD
parentc4f4c33fb304c4d2504d2785e1b6a65ce22f1710 (diff)
downloadaur-fbea70214e1393c05326b4707e6c03772c19df23.tar.gz
Import upstream compatibility patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79fec7bb5298..79ddc8edacd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
url="https://github.com/papis/papis"
@@ -28,10 +28,20 @@ depends=('python'
'python-tqdm'
)
optdepends=('papis-rofi: integration with rofi')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
+ "73e740b17d47e3ccddc72b58221f21a431b49d46.patch")
+sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42'
+ '90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc'
+ '0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d')
noextract=()
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p 1 -i "${srcdir}/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
+ patch -p 1 -i "${srcdir}/73e740b17d47e3ccddc72b58221f21a431b49d46.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i '/configparser/d' setup.py