summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrh9952015-06-10 21:56:54 -0800
committerrh9952015-06-10 21:56:54 -0800
commit203113a6325bc86e9a552c398bb516a8d88fe610 (patch)
tree3c66910df4c703b07708f5f59edf10790de21b57 /PKGBUILD
downloadaur-203113a6325bc86e9a552c398bb516a8d88fe610.tar.gz
Migrated from AUR 3.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22c5af283ed4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ray Hogenson <rayhogenson@gmail.com>
+pkgname=par
+pkgver=1.52
+pkgrel=4
+pkgdesc="Paragraph reformatter"
+url="http://www.nicemice.net/par/"
+depends=('glibc')
+arch=(i686 x86_64)
+license=('custom')
+source=(http://www.nicemice.net/par/Par152.tar.gz)
+md5sums=('4ccacd824171ba2c2f14fb8aba78b9bf')
+_dirname="Par152"
+
+prepare() {
+ cd "$_dirname"
+}
+build() {
+ cd "$_dirname"
+ make -f protoMakefile
+}
+package() {
+ cd "$_dirname"
+ install --mode=755 -D par "$pkgdir/usr/bin/par"
+ install --mode=644 -D par.1 "$pkgdir/usr/share/man/man1/par.1"
+ install --mode=644 -D par.doc "$pkgdir/usr/share/licenses/$pkgname/par.doc"
+}
+