summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpancho horrillo2018-09-29 22:36:00 +0200
committerpancho horrillo2018-09-29 22:36:00 +0200
commit4d933bce2302231dc906233cabae8d9c83bc237f (patch)
treeffd3238d3287a355d01bb5dcfc5e6083bb081ea8 /PKGBUILD
parente17667c2c894f0ba88a6d5a334670b2c178e9940 (diff)
downloadaur-4d933bce2302231dc906233cabae8d9c83bc237f.tar.gz
Cleanup after adoption + i18n patch
The _GNU_SOURCE must be defined in order to avoid a compiler warning regarding the wcwidth() function from the standard library, which is used by the i18n patch. Thanks to basileios for providing the patching code!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 214a1157a7f3..090212e34530 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
-# Maintainer: Ray Hogenson <rayhogenson@gmail.com>
+# Maintainer: pancho horrillo <pancho at pancho dot name>
+# Contributor: Ray Hogenson <rayhogenson at gmail dot com>
pkgname=par
pkgver=1.52
-pkgrel=4
-pkgdesc="Paragraph reformatter"
-url="http://www.nicemice.net/par/"
-depends=('glibc')
-arch=(i686 x86_64)
+pkgrel=5
+pkgdesc='Paragraph reformatter'
+url='http://www.nicemice.net/par/'
+depends=()
+arch=('x86_64')
license=('custom')
-source=(http://www.sourcefiles.org/Utilities/Text_Utilities/Par152.tar.gz)
-md5sums=('4ccacd824171ba2c2f14fb8aba78b9bf')
-_dirname="Par152"
+source=('http://www.nicemice.net/par/Par152.tar.gz'
+ 'http://sysmic.org/dl/par/par-1.52-i18n.4.patch')
+sha512sums=('f5a46da4b693e6a3d15ccd57e24ee9b0332ebfbcfc88da9ef0731e18932ba6f0adde7691a233264d6361e8903ff7e2263f71885a415c896dc4c45a0d05b1978e'
+ '40af77123cbecb39c465dad9875d4e37914457da4a513c3e37634fbabedef8f839d9dff392fabc272665aa153e89d436cb87121e86fd279aae97656383914f01')
+_dirname='Par152'
prepare() {
cd "$_dirname"
+ patch -Np1 -i "$srcdir/par-1.52-i18n.4.patch"
}
+
build() {
cd "$_dirname"
- make -f protoMakefile
+ make -f protoMakefile CC='cc -D_GNU_SOURCE -std=c99 -c'
}
+
package() {
cd "$_dirname"
install --mode=755 -D par "$pkgdir/usr/bin/par"
install --mode=644 -D par.1 "$pkgdir/usr/share/man/man1/par.1"
install --mode=644 -D par.doc "$pkgdir/usr/share/licenses/$pkgname/par.doc"
}
-