summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Phillips2019-10-09 20:16:24 +1300
committerDavid Phillips2019-10-09 20:16:24 +1300
commit5c7a522141ae7d64a55069e7f6becb8f9e8a28d5 (patch)
tree82b9fd292d3084945e1839279e7096f83ff3bf68 /PKGBUILD
parent822f50c8fe84dde0e4d3fe65a13a2588cb069bbb (diff)
downloadaur-5c7a522141ae7d64a55069e7f6becb8f9e8a28d5.tar.gz
Add patch to fix build (harfbuzz include dir)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a309b34ecacd..6142aa1f671d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,17 @@ arch=('i686' 'x86_64' 'armv6h')
url="https://git.nah.nz/${pkgname}/"
license=('GPL')
depends=('gtk3' 'sudo')
-source=("https://git.nah.nz/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.xz")
-sha512sums=('03b885a35429d04b6ce9212b7fe95e7f7e2d7e6fdbae7ec08f47bed1ff94f2d6e596f462d511ed5ae8f29f82c272b4614701661f9ca1613d33fb14e97b8db2c6')
+source=("https://git.nah.nz/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.xz"
+ "0001-Add-missing-harfbuzz-include-dir-to-search-path.patch")
+sha512sums=('03b885a35429d04b6ce9212b7fe95e7f7e2d7e6fdbae7ec08f47bed1ff94f2d6e596f462d511ed5ae8f29f82c272b4614701661f9ca1613d33fb14e97b8db2c6'
+ '44f10d13dc71ef9022311e3ae729d02749012961eb653a52d652fd4e8b4e43497ffee7131a626bd5e44258087183f2b7419d5881859d2de94a22250457c2d5a4')
backup=('etc/paramano.conf')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-Add-missing-harfbuzz-include-dir-to-search-path.patch"
+}
+
build() {
make -C "${srcdir}/${pkgname}-${pkgver}" all
}